Multicopter > Flight Controllers

KK2 problems

<< < (2/2)

Jaymun:

--- Quote from: Gav on March 23, 2013, 10:51:22 PM ---I'd open a paypal dispute straight away if the board is faulty. 

HobbyKing after sales service is a slow slog so just open dispute to get things moving.

Ps did you do a throttle range calibration by pressing and holding down buttons 1 and 4 on the KK (just checking)

--- End quote ---

Yeah I tried that but nothing changed :(


--- Quote from: cortex on March 23, 2013, 10:58:00 PM ---
--- Quote from: Jaymun on March 23, 2013, 10:34:26 PM ---
--- Quote from: cortex on March 23, 2013, 10:32:42 PM ---What esc's are they?

Are the negatives esc wires on the leading edge of the board?

How is the KK2 being powered?

--- End quote ---



They are 25a plush ESCs, all wired correctly and work as Ive tested them on another kk2 Ive got on my quad.
The power is coming from the bec from the M1 ESC

--- End quote ---


Is the LCD coming on?

--- End quote ---

As far as I can tell everything works fine aside from only the one set of pins working :S

cortex:
Send it back get a new one then m8. Sounds dodge

mike:
connect bec-power to m1 and another bec to m2

FPVSimon:
The KK2 is a bit strange in that it need power to M1 and power to M2-M8. I had mine wired to take the M1 power off the ESC an the rest off a BEC.

Jaymun:
All of the connections to the escs are powered by the escs becs, the same setup works perfectly on my other kk2 board so it must just be faulty :S

Sent from my GT-I9100 using Tapatalk 2

Navigation

[0] Message Index

[*] Previous page

Go to full version